WickedFire - Affiliate Marketing Forum - Internet Marketing Webmaster SEO Forum

Go Back   WickedFire - Affiliate Marketing Forum - Internet Marketing Webmaster SEO Forum > >

Newbie Questions New to the whole making money online and developing your own sites thing? Post your questions here so that seasoned members can answer your questions. Please keep your questions out of the other categories. We know you're a newbie, but there's no reason to be annoying.


Welcome to the WickedFire - Affiliate Marketing Forum - Internet Marketing Webmaster SEO Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Reply
 
Thread Tools Display Modes
Old 02-17-2012, 09:24 AM   #1
vinnypolston
inbound.pro
 
vinnypolston's Avatar
 
Join Date: Mar 2011
Posts: 363
iTrader: 23 / 100%
vinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond repute
Question No titles

Hey all,

I've been working on my website that promotes a clickbank product.

Important Information:
-Wordpress
-Using theme 'Skeptical' by WooThemes
-Tried both ( at different times )All in one SEO and Yoast SEO plugins

Problem:
It doesn't seem to matter which plugin I use.. My meta description shows up correctly in serps but my page title absolutely will NOT. I'm sitting spots 4 and 5 for my main terms and have pagerank 3. But I get few click throughs because my title doesn't draw attention..

Any ideas? This has been driving me crazy!

Thanks!
Vinny
vinnypolston is offline   Reply With Quote
Sponsored Ad
Old 02-17-2012, 10:40 AM   #2
thosmi
Member
 
thosmi's Avatar
 
Join Date: Jul 2007
Posts: 116
iTrader: 30 / 100%
thosmi has a spectacular aura about
Do you see the correct page title when your site is loaded in the browser?
thosmi is offline   Reply With Quote
Old 02-17-2012, 11:38 AM   #3
vinnypolston
inbound.pro
 
vinnypolston's Avatar
 
Join Date: Mar 2011
Posts: 363
iTrader: 23 / 100%
vinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond repute
You're right - I checked in both FireFox and Internet Explorer and both display correct page title

:EDIT:
Unfortunately although the page title shows up in browsers fine.. when it comes to SEO when I google my terms it still just shows generic and not my updated one.

Last edited by vinnypolston; 02-17-2012 at 05:18 PM..
vinnypolston is offline   Reply With Quote
Old 02-17-2012, 09:30 PM   #4
thosmi
Member
 
thosmi's Avatar
 
Join Date: Jul 2007
Posts: 116
iTrader: 30 / 100%
thosmi has a spectacular aura about
You could pm me the url to have a look at it for you.
thosmi is offline   Reply With Quote
Old 02-17-2012, 09:52 PM   #5
wikifire
Banned
 
Join Date: Jan 2012
Location: In The Fire
Posts: 41
iTrader: 0 / 0%
wikifire wikifire wikifire wikifire wikifire wikifire wikifire wikifire wikifire wikifire wikifire
I think.it will.just take some time for.google.to get it right. I've seen google doing mistakes before.
wikifire is offline   Reply With Quote
Old 02-17-2012, 10:54 PM   #6
Elvis
9" Member
 
Elvis's Avatar
 
Join Date: Oct 2006
Location: A yurt.
Posts: 392
iTrader: 18 / 100%
Elvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond repute
Has Google crawled your page since you last updated page titles?
Elvis is offline   Reply With Quote
Old 02-22-2012, 08:53 AM   #7
vinnypolston
inbound.pro
 
vinnypolston's Avatar
 
Join Date: Mar 2011
Posts: 363
iTrader: 23 / 100%
vinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond reputevinnypolston has a reputation beyond repute
Yea Google has crawled my page. I just noticed that the theme has built in SEO that would be conflicting with the plugin. I disabled the theme SEO just now. Will post results

Thanks for the suggestions
vinnypolston is offline   Reply With Quote
Old 02-22-2012, 09:26 AM   #8
Elvis
9" Member
 
Elvis's Avatar
 
Join Date: Oct 2006
Location: A yurt.
Posts: 392
iTrader: 18 / 100%
Elvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond reputeElvis has a reputation beyond repute
I've had the same issue with WooThemes. Can't believe I didn't think of that! That should fix it though.
Elvis is offline   Reply With Quote
Old 06-30-2012, 12:39 AM   #9
zarrakdesigner.
Banned
 
Join Date: Jun 2012
Posts: 91
iTrader: 11 / 100%
zarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond reputezarrakdesigner. has a reputation beyond repute
Sounds Good Thanks For Share It Mate Great...
zarrakdesigner. is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:38 AM.


Search Engine Optimisation provided by DragonByte SEO v1.2.9 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
WickedFire.com Copyright 2014 - WickedFire is an international registered Trademark of Coastal Synergy LLC. You may not use any of our trademarks, copyrights, content, or images without a written approval by members of Coastal Synergy LLC. "Banners on this site that promote Wickedfire are satire unless clearly stamped as REAL".