Prosper202 Migration error - Please help!

sumohax0r

what that be like?
Nov 1, 2009
740
41
0
127.0.0.1
Hey everyone,

I migrated my server to another faster box and now my prospers are throwing this error, --- they seem to still be working but huge lists of these errors on top of everything is really annoying and the charts are messed up.

here is the error. Anyone have any ideas? I tried resetting the time zone in my account but didnt help.

ERROR:

Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EST/-5.0/no DST' instead in /var/www/vhosts/domain.com/subdomains/sub_domain/httpdocs/202-cronjobs/index.php on line 124 Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EST/-5.0/no DST' instead in /var/www/vhosts/domain.com/subdomains/subdomain/httpdocs/202-cronjobs/index.php on line 125

it just keeps going on like that for a few hundred lines.

PLEASE HELP! I don't want to lose all stats and have to reinstall and reconfigure.
 


humm looks like its a warning
try updating error_reporting in php.ini and reload apache
error_reporting = E_ALL & ~E_NOTICE

or

add the following to your .htaccess file
php_value error_reporting 6135

and see if that helps
 
  • Like
Reactions: sumohax0r
I got this exact same error when migrating my database too. Go to your index.php file in the 202-cronjobs and add your default timezone. So for me it was los angeles so I added this into the php file

date_default_timezone_set('America/Los_Angeles');


here is a link to all the different timezones so you can find yours

PHP: America - Manual

Are you upgrading to a DV at mediatemple?
 
  • Like
Reactions: sumohax0r
Problem SOLVED!

restarted server and its working fine.

humm looks like its a warning
try updating error_reporting in php.ini and reload apache
error_reporting = E_ALL & ~E_NOTICE

or

add the following to your .htaccess file
php_value error_reporting 6135

and see if that helps

Thanks for the info!

I got this exact same error when migrating my database too. Go to your index.php file in the 202-cronjobs and add your default timezone. So for me it was los angeles so I added this into the php file

date_default_timezone_set('America/Los_Angeles');


here is a link to all the different timezones so you can find yours

PHP: America - Manual

Are you upgrading to a DV at mediatemple?

Yes and no - I had a DV, moved from the 3.5 version to 4.0 and upgraded it.

It is Media Temple.
 
I got this exact same error when migrating my database too. Go to your index.php file in the 202-cronjobs and add your default timezone. So for me it was los angeles so I added this into the php file

date_default_timezone_set('America/Los_Angeles');


here is a link to all the different timezones so you can find yours

PHP: America - Manual

Are you upgrading to a DV at mediatemple?

So after beliveing it was fixed the error was still coming up ONLY on my Macbook and not my PC desktop -- I cleared cache just to be sure but sure nuff it was still throwing error.

Added the line you said above but for New_York and presto! it was fixed

YOUR THE MAN NOW DAWG!